• “阿里、腾讯、微软、苏宁、京东、电信”合作服务商
  • 028-658861117X24热线:18080923400
如何选择不同的PHP版本?
[主机管理系统]  2015-12-10 11:07:43

    由于各种因素,导致了PHP版本的碎片化。PHP的向下不兼容导致了PHP程序的移植性很差。因此才会有不同版本的PHP要求选择的需求。

 

    护卫神主机系统,为您解决了这个烦恼,同一台服务器上,配备了PHP5.2/PHP5.3/PHP5.4/PHP5.5/PHP5.6 一共5个版本,每个网站均可以自己独立选择所需的PHP版本,与其他网站相互不干扰,完全满足您多版本PHP的需求,且支持主机系统一键切换。

    在阿里云镜像中,PHP5.2/5.3/5.4为32位程序,支持Zend解密,PHP5.5/5.6为64位程序,不支持Zend解密,请各位根据实际情况选择。

    一般而言,DEDECMS原版支持PHP5.2版,其他CMS程序请根据实际运行环境对应切换即可。

如何选择不同的PHP版本

 

    以下简单介绍不同的PHP之间的区别:

        PHP5.2 以前:autoload, PDO 和 MySQLi, 类型约束

        PHP5.2:JSON 支持

        PHP5.3:弃用的功能,匿名函数,新增魔术方法,命名空间,后期静态绑定,Heredoc 和 Nowdoc, const, 三元运算符,Phar

        PHP5.4:Short Open Tag, 数组简写形式,Traits, 内置 Web 服务器,细节修改

        PHP5.5:yield, list() 用于 foreach, 细节修改

        PHP5.6: 常量增强,可变函数参数,命名空间增强。

    更多区别请参考PHP官方。

用户留言